#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s($)<>]+|\(([^\s()<>]+|(\([^\s( )<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s($r)<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))"
Local $sString = "https://www.linkedin.com/in/amalia-" & @CRLF & _
"daniela-nicolaita-78021870"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")