// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s($)<>]+|\(([^\s()<>]+|(\([^\s( )<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s($r)<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))"#).unwrap();
let string = "https://www.linkedin.com/in/amalia-
daniela-nicolaita-78021870";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}