package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s($)<>]+|\(([^\s()<>]+|(\([^\s( )<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s($r)<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))`)
var str = `https://www.linkedin.com/in/amalia-
daniela-nicolaita-78021870`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}