import re
regex = re.compile(r"(?i)\b((?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)(?:[^\s($)<>]+|\(([^\s()<>]+|(\([^\s( )<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s($r)<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))", flags=re.MULTILINE)
test_str = ("https://www.linkedin.com/in/amalia-\n"
"daniela-nicolaita-78021870")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")