#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\(.*?\)|(?!\|>|\s).)*(?:\s*\|>\s*(?:\(.*?\)|(?!\|>|\s).)*)+"
Local $sString = "x() |> y($$) |> z($$) any random string a() |> b($$) |> c($$)" & @CRLF & _
"" & @CRLF & _
"and spaces allowed between paranthesis" & @CRLF & _
"" & @CRLF & _
"x() |> y(a=$$, b=5) |> z($$) any random string a() |> b($$) |> c($$)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")