import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\(.*?\\)|(?!\\|>|\\s).)*(?:\\s*\\|>\\s*(?:\\(.*?\\)|(?!\\|>|\\s).)*)+";
final String string = "x() |> y($$) |> z($$) any random string a() |> b($$) |> c($$)\n\n"
+ "and spaces allowed between paranthesis\n\n"
+ "x() |> y(a=$$, b=5) |> z($$) any random string a() |> b($$) |> c($$)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}