using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(.*?\)|(?!\|>|\s).)*(?:\s*\|>\s*(?:\(.*?\)|(?!\|>|\s).)*)+";
string input = @"x() |> y($$) |> z($$) any random string a() |> b($$) |> c($$)
and spaces allowed between paranthesis
x() |> y(a=$$, b=5) |> z($$) any random string a() |> b($$) |> c($$)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}