$re = '/(?:\(.*?\)|(?!\|>|\s).)*(?:\s*\|>\s*(?:\(.*?\)|(?!\|>|\s).)*)+/';
$str = 'x() |> y($$) |> z($$) any random string a() |> b($$) |> c($$)
and spaces allowed between paranthesis
x() |> y(a=$$, b=5) |> z($$) any random string a() |> b($$) |> c($$)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);