package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\|[\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?)$`)
var str = `aaa|45.85[u]52.22 - 43.75 - 36.5[d]25.75
bbb|238.4[u]345.45 - 24.1[d]13.85 - 56.4[d]56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}