import re
regex = re.compile(r"^(.*?)\|[\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?)$", flags=re.MULTILINE)
test_str = ("aaa|45.85[u]52.22 - 43.75 - 36.5[d]25.75\n"
"bbb|238.4[u]345.45 - 24.1[d]13.85 - 56.4[d]56")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")