$re = '/^(.*?)\|[\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?) - [\w\[\.]+\]?(.*?)$/m';
$str = 'aaa|45.85[u]52.22 - 43.75 - 36.5[d]25.75
bbb|238.4[u]345.45 - 24.1[d]13.85 - 56.4[d]56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);