import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\|[\\w\\[\\.]+\\]?(.*?) - [\\w\\[\\.]+\\]?(.*?) - [\\w\\[\\.]+\\]?(.*?)$";
final String string = "aaa|45.85[u]52.22 - 43.75 - 36.5[d]25.75\n"
+ "bbb|238.4[u]345.45 - 24.1[d]13.85 - 56.4[d]56";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}