package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)codez`)
var str = `(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/720P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/480P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/240P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}