const regex = /codez/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('codez', 'gm')
const str = `(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/720P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})
(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/480P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})
(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/240P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}