import Foundation
let pattern = #"codez"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/720P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/480P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})
(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/240P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)