using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[+-])?(?:(?:0?\.[0-9]*)|(?:[1-9]+\.?[0-9]*))(?:[eE][+-]?(?:(?:0?\.[0-9]*)|(?:[0-9]+\.?[0-9]*)))?)|(0x[0-9a-fA-F]+)|(0[0-9]*)";
string input = @"Matching Groups:
===============================
Group 0x1: hexadecimal numbers
Group 02: octal numbers
Group 3: decimal numbers
1, 04, 3., +1.2e4, -0.03E-4, -.456E+003, - 04, .e4, 1.3e
-0.04e-03 0x024 0 0x 0xG 0xF 0xf 0x3.4 0123345
-00 -0xf.3e0f 0xFF00233 e09 e0xk22";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}