// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:[+-])?(?:(?:0?\.[0-9]*)|(?:[1-9]+\.?[0-9]*))(?:[eE][+-]?(?:(?:0?\.[0-9]*)|(?:[0-9]+\.?[0-9]*)))?)|(0x[0-9a-fA-F]+)|(0[0-9]*)").unwrap();
let string = "Matching Groups:
===============================
Group 0x1: hexadecimal numbers
Group 02: octal numbers
Group 3: decimal numbers
1, 04, 3., +1.2e4, -0.03E-4, -.456E+003, - 04, .e4, 1.3e
-0.04e-03 0x024 0 0x 0xG 0xF 0xf 0x3.4 0123345
-00 -0xf.3e0f 0xFF00233 e09 e0xk22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}