using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)(?<=^Episode\n).*(?=\nBeschreibung)";
string input = @"Episode
1
2
3
4
5
6
Beschreibung
Hier steht eine Beschreibung
usw.
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}