const regex = /(?sm)(?<=^Episode\n).*(?=\nBeschreibung)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)(?<=^Episode\\n).*(?=\\nBeschreibung)', '')
const str = `Episode
1
2
3
4
5
6
Beschreibung
Hier steht eine Beschreibung
usw.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}