$re = '/(?sm)(?<=^Episode\n).*(?=\nBeschreibung)/';
$str = 'Episode
1
2
3
4
5
6
Beschreibung
Hier steht eine Beschreibung
usw.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);