re = /(?sm)(?<=^Episode\n).*(?=\nBeschreibung)/
str = 'Episode
1
2
3
4
5
6
Beschreibung
Hier steht eine Beschreibung
usw.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end