package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d*,?\d*,?\d{0,3}\.\d\d`)
var str = `no_money_letter = """
Hey Boss:
Just so you know, I did all the crimes. Like 100 of them. So many crimes.
We should probably delete this e-mail before we get sued.
xoxoxo,
Lackey.
"""
invoice = """
Crime, INC.
For services rendered:
Tax Fraud 100.00
Price-fixing 9.99
Insider trading 20.00
TOTAL 129.99
"""
money_letter = """
Dear Boss:
Remember all those crimes I've committed? They made the firm $1,280,012.05. Maybe a raise?
xoxoxo,
Lackey
"""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}