import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*,?\\d*,?\\d{0,3}\\.\\d\\d";
final String string = "no_money_letter = \"\"\"\n"
+ "Hey Boss: \n\n"
+ "Just so you know, I did all the crimes. Like 100 of them. So many crimes. \n\n"
+ "We should probably delete this e-mail before we get sued.\n\n"
+ "xoxoxo,\n\n"
+ "Lackey.\n\n"
+ "\"\"\"\n\n"
+ "invoice = \"\"\"\n\n"
+ "Crime, INC.\n\n"
+ "For services rendered: \n\n"
+ "Tax Fraud 100.00\n\n"
+ "Price-fixing 9.99\n\n"
+ "Insider trading 20.00\n\n"
+ "TOTAL 129.99 \n\n"
+ "\"\"\"\n\n"
+ "money_letter = \"\"\"\n\n"
+ "Dear Boss:\n\n"
+ "Remember all those crimes I've committed? They made the firm $1,280,012.05. Maybe a raise?\n\n"
+ "xoxoxo,\n\n"
+ "Lackey\n\n"
+ "\"\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}