# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d*,?\d*,?\d{0,3}\.\d\d"
test_str = ("no_money_letter = \"\"\"\n"
"Hey Boss: \n\n"
"Just so you know, I did all the crimes. Like 100 of them. So many crimes. \n\n"
"We should probably delete this e-mail before we get sued.\n\n"
"xoxoxo,\n\n"
"Lackey.\n\n"
"\"\"\"\n\n"
"invoice = \"\"\"\n\n"
"Crime, INC.\n\n"
"For services rendered: \n\n"
"Tax Fraud 100.00\n\n"
"Price-fixing 9.99\n\n"
"Insider trading 20.00\n\n"
"TOTAL 129.99 \n\n"
"\"\"\"\n\n"
"money_letter = \"\"\"\n\n"
"Dear Boss:\n\n"
"Remember all those crimes I've committed? They made the firm $1,280,012.05. Maybe a raise?\n\n"
"xoxoxo,\n\n"
"Lackey\n\n"
"\"\"\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.