import Foundation
let pattern = #"\d*,?\d*,?\d{0,3}\.\d\d"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
no_money_letter = """
Hey Boss:
Just so you know, I did all the crimes. Like 100 of them. So many crimes.
We should probably delete this e-mail before we get sued.
xoxoxo,
Lackey.
"""
invoice = """
Crime, INC.
For services rendered:
Tax Fraud 100.00
Price-fixing 9.99
Insider trading 20.00
TOTAL 129.99
"""
money_letter = """
Dear Boss:
Remember all those crimes I've committed? They made the firm $1,280,012.05. Maybe a raise?
xoxoxo,
Lackey
"""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)