import re
regex = re.compile(r"^([a-zA-Z]*)\s*([\d\/\s\,]*)\s*(.*)$", flags=re.MULTILINE)
test_str = ("17a Taylor Street\n"
"13/1 McDougall St\n"
"76 Lyndhurst street \n"
"PO Box 177\n"
"30 Sunbeam Road \n"
"Level 24, 17-24 Kippax St")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")