re = /^([a-zA-Z]*)\s*([\d\/\s\,]*)\s*(.*)$/m
str = '17a Taylor Street
13/1 McDougall St
76 Lyndhurst street
PO Box 177
30 Sunbeam Road
Level 24, 17-24 Kippax St'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end