const regex = new RegExp('.*/it-jobs/[^/\\s]+$', 'gm')
const str = `www.website.com/it-jobs/
- is not a match
is a match
www.website.com/it-jobs/java-developer
www.website.com/it-jobs/php
www.website.com/it-jobs/angular-developer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}