$re = '~.*/it-jobs/[^/\s]+$~m';
$str = 'www.website.com/it-jobs/
- is not a match
is a match
www.website.com/it-jobs/java-developer
www.website.com/it-jobs/php
www.website.com/it-jobs/angular-developer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);