// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*/it-jobs/[^/\s]+$").unwrap();
let string = "www.website.com/it-jobs/
- is not a match
is a match
www.website.com/it-jobs/java-developer
www.website.com/it-jobs/php
www.website.com/it-jobs/angular-developer";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}