re = /.*\/it-jobs\/[^\/\s]+$/m
str = 'www.website.com/it-jobs/
- is not a match
is a match
www.website.com/it-jobs/java-developer
www.website.com/it-jobs/php
www.website.com/it-jobs/angular-developer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end