using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(.*?([A-Z]{1,5}_[A-Z]{1}_\d{3}_\w{1,24})(?=.*?\2.*?).*?\))";
string input = @"RESP_C_777_VAR1 IN (408, 409) OR (RESP_C_777_VAR1 = 231 AND IN_T_032_DATE >= 20220101 AND IN_T_032_DATE <20220301) OR (RESP_C_777_VAR1 = 232 AND RESP_C_777_VAR1 <= 240)
RESP_C_777_VAR1 RESP_C_777_VAR1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}