$re = '/(\(.*?([A-Z]{1,5}_[A-Z]{1}_\d{3}_\w{1,24})(?=.*?\2.*?).*?\))/m';
$str = 'RESP_C_777_VAR1 IN (408, 409) OR (RESP_C_777_VAR1 = 231 AND IN_T_032_DATE >= 20220101 AND IN_T_032_DATE <20220301) OR (RESP_C_777_VAR1 = 232 AND RESP_C_777_VAR1 <= 240)
RESP_C_777_VAR1 RESP_C_777_VAR1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);