const regex = /(\(.*?([A-Z]{1,5}_[A-Z]{1}_\d{3}_\w{1,24})(?=.*?\2.*?).*?\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(.*?([A-Z]{1,5}_[A-Z]{1}_\\d{3}_\\w{1,24})(?=.*?\\2.*?).*?\\))', 'gm')
const str = `RESP_C_777_VAR1 IN (408, 409) OR (RESP_C_777_VAR1 = 231 AND IN_T_032_DATE >= 20220101 AND IN_T_032_DATE <20220301) OR (RESP_C_777_VAR1 = 232 AND RESP_C_777_VAR1 <= 240)
RESP_C_777_VAR1 RESP_C_777_VAR1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}