import re
regex = re.compile(r"(\(.*?([A-Z]{1,5}_[A-Z]{1}_\d{3}_\w{1,24})(?=.*?\2.*?).*?\))", flags=re.MULTILINE)
test_str = ("RESP_C_777_VAR1 IN (408, 409) OR (RESP_C_777_VAR1 = 231 AND IN_T_032_DATE >= 20220101 AND IN_T_032_DATE <20220301) OR (RESP_C_777_VAR1 = 232 AND RESP_C_777_VAR1 <= 240)\n\n"
"RESP_C_777_VAR1 RESP_C_777_VAR1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")