using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\\x\d\d]|[^\\x\w\d]|[^\\x\d\w]";
string input = @"CRT\x00\x00\x00\x00\x00G3\x00\x00\x00\x00\x00\x00\x80\x10a\x06\x00\x00\x00\x00\x16@E\x00\x00\x00\x00\x00\x00\x00\x00\x00\x13";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}