package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\\x\d\d]|[^\\x\w\d]|[^\\x\d\w]`)
var str = `CRT\x00\x00\x00\x00\x00G3\x00\x00\x00\x00\x00\x00\x80\x10a\x06\x00\x00\x00\x00\x16@E\x00\x00\x00\x00\x00\x00\x00\x00\x00\x13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}