// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\\x\d\d]|[^\\x\w\d]|[^\\x\d\w]").unwrap();
let string = "CRT\\x00\\x00\\x00\\x00\\x00G3\\x00\\x00\\x00\\x00\\x00\\x00\\x80\\x10a\\x06\\x00\\x00\\x00\\x00\\x16@E\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x13";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}