using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<val>)(.*?,.*?,.*?,.*?,)(\s*.+?)(,.*$)";
string input = @"<val>5,0,10R,7,#1 Date Month text (Utility) Wordlist P4,null_val_func";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}