package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<val>)(.*?,.*?,.*?,.*?,)(\s*.+?)(,.*$)`)
var str = `<val>5,0,10R,7,#1 Date Month text (Utility) Wordlist P4,null_val_func`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}