#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<)[^>]+(?=>)"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<!-- Text for testing regex -->" & @CRLF & _
"<data type="lorem">" & @CRLF & _
"<h3>Improving the lorem in your ipsum</h3>" & @CRLF & _
"</data>" & @CRLF & _
"<data type="image" number="1"/>" & @CRLF & _
"<data type="ipsum">" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt." & @CRLF & _
"</data>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")