# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<)[^>]+(?=>)"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<!-- Text for testing regex -->\n"
"<data type=\"lorem\">\n"
"<h3>Improving the lorem in your ipsum</h3>\n"
"</data>\n"
"<data type=\"image\" number=\"1\"/>\n"
"<data type=\"ipsum\">\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt.\n"
"</data>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.