using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<)[^>]+(?=>)";
string input = @"<?xml version=""1.0"" encoding=""UTF-8""?>
<!-- Text for testing regex -->
<data type=""lorem"">
<h3>Improving the lorem in your ipsum</h3>
</data>
<data type=""image"" number=""1""/>
<data type=""ipsum"">
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt.
</data>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}