import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<)[^>]+(?=>)";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<!-- Text for testing regex -->\n"
+ "<data type=\"lorem\">\n"
+ "<h3>Improving the lorem in your ipsum</h3>\n"
+ "</data>\n"
+ "<data type=\"image\" number=\"1\"/>\n"
+ "<data type=\"ipsum\">\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt.\n"
+ "</data>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}