#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bMobile:\s*\K\d{3}([ -]?)\d{3}\1\d{4}\b"
Local $sString = "Phone: 111-111-1111 e1t. 215 => return Empty" & @CRLF & _
"" & @CRLF & _
" Phone: 111-111-1111 Mobile: 911-111-1000 => return 911-111-1000" & @CRLF & _
"" & @CRLF & _
" Mobile: 911-111-1000 Phone: 111-111-1111 => return 911-111-1000" & @CRLF & _
"" & @CRLF & _
" Phone: 111-111-1111 Mobile: 911 111 1000 e1t. 215 => return 911-111-1000" & @CRLF & _
"" & @CRLF & _
" Mobile: 911-111-1000 Phone: 111-111-1111 e1t. 215 => return 911-111-1000" & @CRLF & _
"" & @CRLF & _
" Phone: 111-111-1111 e1t. 215 Mobile: 9111111000 => return 911-111-1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")