import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMobile:\\s*\\K\\d{3}([ -]?)\\d{3}\\1\\d{4}\\b";
final String string = "Phone: 111-111-1111 e1t. 215 => return Empty\n\n"
+ " Phone: 111-111-1111 Mobile: 911-111-1000 => return 911-111-1000\n\n"
+ " Mobile: 911-111-1000 Phone: 111-111-1111 => return 911-111-1000\n\n"
+ " Phone: 111-111-1111 Mobile: 911 111 1000 e1t. 215 => return 911-111-1000\n\n"
+ " Mobile: 911-111-1000 Phone: 111-111-1111 e1t. 215 => return 911-111-1000\n\n"
+ " Phone: 111-111-1111 e1t. 215 Mobile: 9111111000 => return 911-111-1000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}