$re = '/\bMobile:\s*\K\d{3}([ -]?)\d{3}\1\d{4}\b/m';
$str = 'Phone: 111-111-1111 e1t. 215 => return Empty
Phone: 111-111-1111 Mobile: 911-111-1000 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 => return 911-111-1000
Phone: 111-111-1111 Mobile: 911 111 1000 e1t. 215 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 e1t. 215 => return 911-111-1000
Phone: 111-111-1111 e1t. 215 Mobile: 9111111000 => return 911-111-1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);