use strict;
my $str = 'Phone: 111-111-1111 e1t. 215 => return Empty
Phone: 111-111-1111 Mobile: 911-111-1000 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 => return 911-111-1000
Phone: 111-111-1111 Mobile: 911 111 1000 e1t. 215 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 e1t. 215 => return 911-111-1000
Phone: 111-111-1111 e1t. 215 Mobile: 9111111000 => return 911-111-1000';
my $regex = qr/\bMobile:\s*\K\d{3}([ -]?)\d{3}\1\d{4}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}