using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMobile:\s*\K\d{3}([ -]?)\d{3}\1\d{4}\b";
string input = @"Phone: 111-111-1111 e1t. 215 => return Empty
Phone: 111-111-1111 Mobile: 911-111-1000 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 => return 911-111-1000
Phone: 111-111-1111 Mobile: 911 111 1000 e1t. 215 => return 911-111-1000
Mobile: 911-111-1000 Phone: 111-111-1111 e1t. 215 => return 911-111-1000
Phone: 111-111-1111 e1t. 215 Mobile: 9111111000 => return 911-111-1000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}