using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"g\.command (<#\d+>)\nhttps?:\/\/[a-z0-9.-]+\n.+";
string input = @"g.command <#123456790>
https://ex1am1m1ple.com
name bla bla
descropsadqwd qw dqw qdw
asd dqw wq dwq dwdwwd
wqdqwdqwidqwdjqwd qwdwq doijqoiw djq";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}